linkage problem

Post Reply
C++User
Posts: 4
Joined: Thu Jun 05, 2008 2:09 pm

linkage problem

Post by C++User » Thu Jun 05, 2008 4:13 pm

Hi for all

I'm testing the "CcdPhysicsDemo" app in my Code::Blocks. My OS is Windows XP Professional.
I created a new project, copied the files to them and link these dirs:
"src", "OpenGL" and "Glut" in my include paths.

Now the problem is the CodeBlocks is telling a lot of undefined references. One of the m is this:
In function "_Z41__static initialization_and_destruction_0ii'
"undefined reference to GLDebugDrawer::GLDebugDrawer()"

So, if someone have used CodeBlocks or not, tell me what's going on.


Thanks for all replies.

User avatar
Erwin Coumans
Site Admin
Posts: 4093
Joined: Sun Jun 26, 2005 6:43 pm
Location: California, USA
Contact:

Re: linkage problem

Post by Erwin Coumans » Thu Jun 05, 2008 6:22 pm

You also need to add the Demos\OpenGL project (libbulletopenglsupport.vcproj).

Doesn't CMake have support to create Codeblocks projectfiles?
Thanks,
Erwin

C++User
Posts: 4
Joined: Thu Jun 05, 2008 2:09 pm

Re: linkage problem

Post by C++User » Thu Jun 19, 2008 9:17 pm

Erwin, cmake have suppor for the codeblocks project. What I need to do now?

User avatar
Erwin Coumans
Site Admin
Posts: 4093
Joined: Sun Jun 26, 2005 6:43 pm
Location: California, USA
Contact:

Re: linkage problem

Post by Erwin Coumans » Fri Jun 20, 2008 8:20 am

Please download cmake and generate codeblocks project files.

If you have problems using cmake or codeblocks, please ask the cmake and/or codeblocks community for help,
Thanks,
Erwin

Post Reply