Page 1 of 1

App_PhysicsServer_SharedMemory_VR stops responding immediately when connecting to headset

Posted: Sun Dec 11, 2022 2:40 pm
by RRachel
I am trying to use pybullet in VR with an Oculus Quest.
I downloaded the current release of bullet from github, used the build_visual_studio_vr_pybullet_double.bat to create the Visual Studio project and built the exe file using Visual Studio. Whenever I execute the App_PhysicsServer_SharedMemory_VR.exe, SteamVR opens, the controllers and headset are recognized and the headset shows a popup that it is waiting for the application, but the helloVR_bullet window immediately stops responding instead of showing the empty world with controllers on the headset as described in the quickstart guide.

I have already double-checked that the bat script points towards the right python version and that pybullet is installed properly and that Steam VR recognizes the headset and controllers. I also tried this both with a cable and air link connection to the oculus quest headset and with a HTC Vive with the same result.

I attached a screenshot of what the terminal and frozen window look like when I start the program and would be very thankful for any suggestions or hints of what I'm missing here.