Page 1 of 1

btRgidBody goes to deactivation state seconds after application starts, no matter what.

Posted: Fri Jun 17, 2022 7:11 am
by playrt

using bullet3-master branch on github, compiled, and linked to my ogre3d project using their OgreBullet utils.

Im trying to avoid the rigidbody capsule to go to permafrost

Youtube video :

rigidbody_state_frozen.gif (3.43 MiB) Viewed 174 times

Now when i create the rigid body i specify

Code: Select all

This is executed when i press a key, even i added it to the rendering loop, changes absolutely nothing.

Code: Select all

rigidbody keeps going to state 2, after a few seconds, and cant interact anymore with it.
There is no way to change the state once it was changed to 2.

I display the activation state, no matter what i do, once it is set to 2 it is not changing to anything else. Highlighted in red box on the screenshot.

Code: Select all

ImGui::Text("Sinbad state : %i", sinbadBody->getActivationState());
rigidbody_state_change_problem.png (881.33 KiB) Viewed 179 times

I also tried removing/re-adding the rigidbody to the world, it remains in the same state. lol. how is this supposed to work ?
This is just the simplest rigibody sample i could find, and all i get is permafrost.

Re: btRgidBody goes to deactivation state seconds after application starts, no matter what.

Posted: Sat Jun 18, 2022 7:02 am
by playrt
Here is the problem :

ogre 13.4.0 precompiled sdk doesnt provide bullet lib, so i had to download a separate bullet from github, the problem is that i linked this version and it had invisible issues that didnt show up at compilation.

downloading ogre source, using cmake it downloads dependencies including the correct bullet version, and it solved my problem.

That's insane because most bullet features were working except that activation function.