CMake using obsolete GLU Package

Post Reply
d3x0r
Posts: 51
Joined: Tue Dec 11, 2012 9:59 pm

CMake using obsolete GLU Package

Post by d3x0r » Fri Jan 11, 2013 6:57 pm

It's amusing to me :)

The beginning of bullet's cmake is
cmake_minimum_required(VERSION 2.4.3)

And then later including FindPackage( GLU ) which is throwing a warning that it's obsolete and to use opengl instead. (opengl is already used)

In the FindGLU.Cmake module
----------------------
# Use of this file is deprecated, and is here for backwards compatibility with CMake 1.4
# GLU library is now found by FindOpenGL.cmake
#

MESSAGE(STATUS
"WARNING: you are using the obsolete 'GLU' package, please use 'OpenGL' instead")
----------------------

But if the required version is already 2.something, why use a 1.4 findpackage?

Post Reply